SSH Connections - client_loop: send disconnect: Broken pipe

Messages
315
Location
Shimla, India
ISP
BSNL
Been facing issue with SSH connections where it gets disconnected after 2-3 minutes of inactivity.
Have tried searching for this issue but the solutions to set ssh config settings on server and client side doesn't seem to work.
The issue is only with Jio Fiber connection.

For testing same server, same client machine while connected from BSNL FTTH, Airtel FTTH etc never does this. With BSNL and Airtel the connection remain active for hours unless there's a network issue or machine goes to sleet never disconnects.
Have tried using Openwrt router instead of Jio ONT wifi.

Client Device: Macbook Air, so it's always WiFi connecting
Servers: DigitalOcean, OVH, Vultr etc

Has anyone else faced similar issues?
 
Broken pipe happens when the ISP/Router drops the TCP Connection. Not sure what is happening here though thats causing it.
 
Yep, it's an issue with jiofiber. Maybe their router automatically drops idle tcp connections or it's something more sinister at their end.
Workaround for putty - set connection keep alive to 30 or 60 seconds in connection settings. For WinSCP use Refresh remote panel in the same way.
 
No issue here, connected to my VPS(In singapore AWS) for more than 10 min and no connection drops
 


If you still have issues add this to your ssh config (on your PC not server).(tested on linux and mac dunno about windows)
Code:
Host *
    ServerAliveInterval 20
    TCPKeepAlive no
 
Why tcp keep alive is set to no?
 
This is because of CGNAT and there isn't much you can do about it(Some techniques will give better results than others but that's about it) It takes CPU/memory resources to keep connections open and they have limited amounts of it so they can't keep your connection open indefinitely. It might be better to just route your SSH Connections over a VPN.
 
@vishalrao Because we will be sending a SSH keep alive message every 20s instead of just tcp ping.
@ishanjain28 Nope, Jio has publicly routable ipv6 and even if connecting via ipv4 there should no issue for ssh client.
 

Back