Firmware upgrade...WTF

  • Thread starter Thread starter nocaps
  • Start date Start date
  • Replies Replies 7
  • Views Views 3,061


Triband 949UL
I downloaded D-Link DSL 502T firmware upgrade V2.00B01T01.ML.20050530_upgradeB05 from dlink support .

My router is connected to the computer through the USB port, and running PPPoE. On the first run of this firmware update tool, I had Sygate Personal firewall on. When the firmware upgrade utility tried to connect to, Sygate confirmation dialog popped up. By the time I acknowledged and allowed access, the upgrade stopped responding.

So on next run, I set SPF to 'allow all' traffic and unchecked 'hide broadcast data'. This time the upgrade appeared to be going fine and the firewall was showing consistent data transfer by the firmware tool. But it was happening only @ 500 bytes/sec. I left the tranfer and waited for over 2 hours. Nearly 5MB data had been tranferred by this firmware upgrade tool, but the transfer just wont stop (Im assuming, to the router. USB lights were flashing madly, ADSL lights were not) ....and the firmware image was just 1.9MB in size.

Finally I got fed up and tried looking for a solution on the net, and found the router was still working...I mean firmware upgrade in progress and simultaneously online 😱

Finally, I prepared myself for a dead router and closed the upgrade tool ctrl-alt-del. Fortunately, its still working. is going on...
well, i really don't have any idea what's going on...but what i'll suggest is u go to their service center and get it updated...that'll be the best thing...btw, have u tried with after disconnecting from internet???just remove the phone line and try and see if it works... all the best!!! 🙂
dude i did the same thing in june via ethernetand the result it got screwed!!!! 🙁 luckly those mtnl peopl gave me new one with the upgraded version 🙂 dude insted of doing it urself go to the D-Link office n do it there.the add is there in ur quick installing guide came with ur modem
Is there really any reason to upgrade the firmware. I think I have the old firmwire but my router is working fine without any problems. I am getting the same 28 - 29 K speed as everybody else.
If it aint broke yet...try to break it so it needs a fix :lol: . Yeah Akash, I know I'm lucky to have got away with it.
@trivisingh...u don't really need to upgrade the firmware if u don't do much R&D in the router...if u just use to connect to the net, it's fine this way... 🙂

hey ppl. are the D-Link ppl doin it for free??
i ws js palnin to play with the router.. (upgrade it my self).. but i feel none of u has been successfull as yet..!!
n ppl it might not b possible wth d usb port since it requires a static ip . n if the connection once breaks.. ur pc might not detect d router properly.. so u ll land in d middle of nowhere..

also u hv to factory reset it before upgrading..
ne wayz it might b better n get it upgraded... if its fr FREE !!

do ne of u no where all r the service centres located??
is there in north delhi...
firmware upgrade is for free...the address and phone numbers are somewhere in this forum's in south delhi...