Help needed: Configuring IPv6 on pfSense with local ISP (D-WAN) /64

Messages
308
Location
Pathanamthitta, Kerala
ISP
BSNL - AS9829
DWAN - AS133301
Hi everyone,
I apologize for posting this on the BSNL thread, but I was hoping to get some help setting up IPv6 with pfSense. I am currently using a local ISP (D-WAN) and have been assigned a /64. I have been able to get it working on the WAN side, but I am having trouble getting it to work on my LAN.
I have tried using the "track interface" option on my LAN, but it hasn't worked. I would really appreciate any help or suggestions that anyone can provide.
Thank you in advance.
 
@WieldyBinkie are you even sure BSNL has started v6 in Kerala? It's not implemented in Pune
 
@Chip BSNL has been conducting IPv6 trials in Kerala since 2019. Unfortunately, my connection is still on the old Redback servers, so I am not able to access IPv6 yet. However, I have been informed by the division engineer that work is currently being done to upgrade the equipment to Juniper.

My secondary ISP recently enabled IPv6 support, and I was able to get it working on my OpenWRT router. However, I am having trouble getting it to work with my pfSense router. I am not very familiar with pfSense, can you help me?
 
Ok, the 1st thing with pfSense is to set your WAN to connection DHCP6 and check the "Request a IPv6 prefix/information through the IPv4 connectivity link" box, set PD value to /64 and check the "Send IPv6 prefix hint" box.

Also uncheck the "Request only an IPv6 prefix" box.

Also, set RA to assisted mode. Do not switch on the router's native DHCPv6. Cross your fingers and reboot the router. 🙂

There are differences from ISP to ISP & what I gave you is for Airtel. With Tata Play it's slightly different as TPBB doesn't assign a v6 to the WAN only delegates to LAN and LAN devices.

So it's best you mirror what you did with your OpenWRT on your pfSense box.
 
I was almost there. All I had to do was reboot the equipment. However, I'm not sure what caused the need for the reboot. Now, I'll have to persuade my contact at the ISP to provide me with a /56 block. Thank you @Chip
 
The standard delegation in India is /64...and frankly is more than enough for a home subnet. I'd like to get a /56 but Airtel would tell me to pi$$ off I guess. 😀 That's an Indian ISP for you...v6 has trillions of addresses but these idiots are still stingy.

In many cases the reboot is requested because the IPv4 has to request the v6 address...once the v4 is set even if you disconnect and reconnect using router controls/GUI, pfSense doesn't get the address. Now I don't know if this is default behavior or a bug.
 


What is the difference between /56 and /64 in terms of benefits or performance?
 
@vishalrao its a larger address space, that's all which lends itself to subnetting if required. Why a home user requires that is beyond me, but we enthu guys always want something extra, no? 😀
 
Hey @Chip, I just had a quick question on ipv6 and pfsense. I was able to get it working with my secondary isp, but now BSNL has started giving out ipv6 and I am unable to use both at the same time. I get ipv6 on wan side on both connections but, I can only get one of them on LAN.
My current config is:
Admin VLAN is set to track BSNL and Wifi VLAN is set to track ISP2, but only 1 works at a time.

Any idea why this might be happening?

EDIT: This only works with static v6, except if I set up 2nd ISP on a different device.
 
Last edited: