Made the Jump from 1gbps Spectra to 300mbps Airtel XStream

Edit: Bridge mode is now working, so I have a public IP on my personal router‘s WAN port now.

I was facing issues with Spectra for quite some time, so decided to change back to Airtel XStream (I had Spectra for around 1 year and Airtel Fiber 300mbps before that). A short timeline

1. Raised request via Airtel app : 11:00
2. Got call from Airtel Sales for document verification : 11:11
3. Got visit from Airtel Sales for document verification : 12:00
4. Got visit from Airtel Technician for GPON/Router installation : 13:00
5. Connection up and running : 13:20

Basically, Airtel has streamlined the entire process. The GPON and the router are now in a single box, which is good news for people who want less clutter, but bad news for people like me who like to use their own router (Moe details about this ahead).

Once the router is connected to the fiber (My house had airtel fiber already, the technician just cut off a bit of fiber and spliced it again) and powered ON, I automatically received a message with the wireless name on the router and password. It looked like the router was provisioned remotely automatically with my account details. Once I visited a link in that same message, I was given an option the chane my Wifi name and password, which again were pushed to the router remotely and setup was done.

However, this was against my wishes of having the public IP on my Netgear Nighthawk router and I didn't want to do double NAT, so

1. I tried configuring the ONT into bridge mode. It doesn't allow that. So the public IP and PPPoE will always be on the ONT
2. I tried configuring my router (R7000) in AP mode, but that disabled guest WiFi which I use
3. I sucked up and configured 2 private networks. One between the ONT LAN and my router WAN and one on my Router's LAN, but this means double NAT
4. I put my Router's WAN IP in DMZ of the ONT. Looks like port forwarding etc. now works as expected

Finally, I get actual 300mbps speeds (On Spectra, speedtest showed my 1Gbps, showed me 50mbps and Netflix was always stuttering). Things look good on Airtel now, however, it looks like this GPON is rated up to 300mbps only and if I need to upgrade to 1Gbps in the future, I would have to get them to change the ONT again, which is not ideal.
Last edited:
Can we have GPON n setup pics?
This is the GPON. I have disabled its wireless and tucked it away behind my cabinet. The LAN goes to my router. The model is Huawei HG8145V5. Let me know if you want anything specific.


  • E0566790-E490-4869-8C86-AA8D92EBAAD8.webp
    50.6 KB · Views: 931

2 Vlans, one for data and one for voice.

Data WAN settings. You cannot change a few settings like Service Type, hence bridge mode cannot be enabled.

I still don't understand why ISPs disable bridge mode? It's not like a normal user would even go in there and change the setting. They should atleast allow it for people who want to use their own router.

Did you try contacting airtel customer care about the bridge mode?
Yes, they said it cannot be disabled. Also, they won't give me the PPPoE password either, so no use. Form their point of view, it makes sense. It allowes them to control the end-to-end setup and they don't have to struggle with people on support.

However, they do agree that they should allow people to voluntarily opt out of this setup with a caveat that they won't bother customer care if they run across issues (Except link issues)
I don't know if it is old or not. When I had Airtel 1 year ago, they gave me the Alcatel Lucent (Nokia) GPON, which didn't have a router built in.

Also, technically, the router allows changing the Data WAN to Bridge while leaving Voice untouched, so that's not it.