MTNL Broadband: How to get top speeds in torrents?

  • Thread starter Thread starter trivsingh
  • Start date Start date
  • Replies Replies 6
  • Views Views 2,146


Hi,I just got a 2Mbps Unlimited Triband plan. But I am having trouble getting good speeds on large torrent files. I use uTorrent and files around 700 MB in size download at 190 ~ 200 KBPS but when i try to download high def movies (around 8 - 9 GB) the download speed varies quite a lot from 20 KBPS to 100 KBPS....anybody knows a reason as to why this is happening. I have done port forwarding and tried all the tweaks mentioned on the net.Thanks, bye
Are you trying to download from public trackers? Then you might not get that speed.I would urge you to download from Private trackers and you would get awesome speeds, Yeh and with good seeders ratio.
and ubuntu torrent usually work great for testing top speeds on a public torrent.
are your ports open? are you using PPPoE via dialer or via router?these can change your speeds...
I guess I am using PPPOE dialer within the router itself, cause it connects by itself....i dont have any software dialer setup. will it make any difference if I setup a software dialer in windows and if so, can you guide me on how to do that. Also how do I get access to private trackers?
if you are using this mode than all ports are blocked and hence you are getting less speeds. Go to your router and enable the dmz for your local single IP. This will solve your problem instantly.

did not matter on mtnl , plan , or utorrent you don't get speed if torrent is bad if torrent is good have alots of seeders and only few leechers then you get full speed if you are trying to download that torrent which are not using by too many peoples then you get very low speed i use private sites for downloading public sites sucks link-removed link-removed pirate bay are suck i use only private site and got full speed like in your plan you will get 218 kbps if you download a torrent from private site torrent size didn't matter :yahoo: torrent can be 200 mb or 100 gb