Ping & weak signal strength issue

  • Thread starter Thread starter Janks
  • Start date Start date
  • Replies Replies 2
  • Views Views 1,210
Messages
2
Location
Budigere, Bangalore
ISP
Airtel Xstream Fiber
So, I have Airtel Xstream Fiber broadband (wifi router+tv streaming box) for around 3 years now. Issue started a month ago - ping fluctuating from 4-50ms. Signal strength from router (ZTE 2antenna) was severely weak from day one.

Ping issue was present for two weeks, when I decided to call their helpline. I informed them of the ping issue first. During the conversation I also stated the signal strength issue. They listened to my issues and transferred to "technical desk". Technical desk heard both my issues, then said they're making some changes to their "back end". Then they asked me to hard reset my router with a pin. Then router came back up and wifi was back to normal ping (4-5ms). Tech person then advised that required changes done, if any issues please use Airtel Thanks app to optimise. Call ended.

After two hours I realised wifi channels were set to 6 & 44 in router console. Since it's an appartment with crowded wifi, I tried to set both to auto. When I apply that, wifi (not full router) turns off, comes back on, and back to channel 6 & 44 in router console settings. After multiple times of this, I tried the optimise wifi option via airtel app. This changed channels but still to manual channel settings in router console, and not to the auto setting. To complicate matters, I was now not able to set the channels manually to a different number in the router console/page.

Called airtel, transferred to technical desk ... person then says he's changes it to "Auto" mode/setting. Not reflecting in my console even after refreshing. Rebooted router, same. Person advised to give it 24 hours. Call ended. After few hours I found I was again able to change channels manually. But not to the auto setting. Same thing if I try setting to auto - wifi goes off, and comes back on to previous manual set channels.

Left it like that for 2 days. But no change. Called again, they sent a tech onsite. Tech came next day, looked at issue, and called someone up who tried to force/push the auto mode setting from their back end but same wifi off on thing. So baffled, he left saying "we will do the update back end". Nothing happened for 24 hours. Post that, numerous calls back & forth, at times airtel calling, to check on issue, but no solution.

After a week of back & forth, router replacement was agreed upon. Tech came, tried to troubleshoot, again on call with their back end support at airtel, but ended baffled. So router replacement was done. A ZyXEL PMG5617-R20B this time.

This router was very good. Excellent signal strength on 5GHz. I want to mention here that while setting up this router, the on site techs did a signal strength check throughout my appartment, and if I'm not mistaken the signal strengths was bumped up via some setting at the Airtel back end who they were on call with while doing the entire setup. So excellent signal strength, back to 4-5ms ping, and channel selection set to auto. All issues resolved very satisfactorily.

Three days down the line (nothing done or changed in router during this time except 1 reboot), I unfortunately decided to do an "optimise wifi" via the Airtel app. Thanks to this app, all of the old issues came back in one shot.

Signal strength is now weaker by 10dbm (5ghz, same channel number) compared to what it was when first set up. Earlier used to be constant -58dbm to -66dbm with very less fluctuations. Now, -65dbm to -75dbm with frequent fluctuations. Same distances/locations etc and same channel number.

Ping fluctuating between 4 - 50ms. Even with my device being only one online and 2 feet from router.

I did a soft reset from console, a hard reset by poking a pin. No change. And numerous power cycles making sure to do this just once in 24hrs.

So. Before risking a call to Airtel again, God forbid that in spite of the person at the other end's best intentions, Airtel's back ends just refuse to align, I'm trying to figure out a few things, listed below. Any help or information will be extremely appreciated 🙏

The firmware running on the router is V100ACCU0b9_RC.
I have no idea of this was the firmware from start, or if this got pushed as an update, after setup. Checked with another forum user who said he was confident his Zyxel router was running this firmware from day one (10 days old). He also says he has had signal strength issues on 5ghz from day one, just like I am now. This is a _RC (release candidate) firmware. Info online says V100ACCU0b8 is latest public firmware as of Dec 2022 and that's what others on this forum are on. Is it the firmware causing the two issues? Are users on V100ACCU0b8 facing signal strength or ping issues?

Is there any way for airtel to change signal strength for my router by changing settings at their back end? This router's console has signal strength settings locked at 100% and greyed out for both frequency bands, from day one, so no user changeable options here.

And finally the ultimate question - what changes did the Airtel Thanks app make that caused the ping to go high (even at 2 feet distance from router) and signal strength to drop by 10dbm?What changed does the app do during "optimisation"?
 
use personal wifi router ....
 
Thanks for the reply.

As I have detailed in the post, this router was initially giving me excellent coverage and signal strength. Until the "optimisation" via Airtel Thanks app damaged both signal strength and ping.

So I really want to know what is it that this "optimisation" via the Airtel app did. Hence my post here. I'm holding back on calling airtel until I figure this out.

Also, when my ZTE router was running, I had a AC1200 running in client+AP mode. Had this with the previous Nokia as well. No problems at all. This extended my coverage with 0 increase in ping times. This I regularly tested and can guarantee. But, when the update was done by airtel technical desk which caused the channel setting issue, it also caused issues with the AC1200. Ping (via AC1200) went up. Pinging via ZTE showed few ms lesser than pinging via AC1200 access point. No settings were changed in the AC1200, and it was switched off during troubleshooting on the call with Airtel. Later, I reset the AC1200 and re configured from scratch, but ping issue remained. So didn't use it.

Then ZyXEL was installed. This I have detailed in initial post. So with excellent signal strength, I didn't need the AC1200 ap. After new issue with the Zyxel showed up, I haven't added the AC1200 to the network. No point complicating an unresolved problem.

Plus, ping on the Zyxel currently fluctuating between 4-55ms, even when testing 1 foot away from router. This was same when issue started a month ago with the ZTE doing routing duties.

So it clearly looks like ping and signal strength are two separate issues. Unfortunately both issues reappeared together on this recently installed Zyxel, immediately after "optimise wifi" was done via the Airtel app, three days after installation. Until then, Zyxel router was running perfectly and no changes done to it except one reboot and no issues after that reboot.

So if I can find cause of the ping issue I might be able to solve this. Which is why I'm asking, what changes does the "optimisation" via Airtel app make, that has caused this two separate issues to show up. I have reverted the changes to the channel number settings made by the app optimisation, but issue still same.
 
Last edited: