Syrotech modem reboots (crashes?) on IPv4/IPv6 mode when full bandwidth is used

  • Thread starter Thread starter shin
  • Start date Start date
  • Replies Replies 9
  • Views Views 4,020
Messages
111
Location
NA
ISP
BSNL BharatFiber
New connection here.
Switched to IPv4 IPv6 dual stack as everyone here was saying v6 is uncapped right now.
Everything works fine, got ipv6 address assigned and everything.
But the moment I run speed test (fast.com) the modem/router reboots. This doesn't happen on ipv4. Since it reboots immediately after starting the test, it just shows 0 speed but Gnome system monitor shows a huge spike, sometimes upto 80 MiB/s and disconnects after that.

I don't have a router with GbE port right now. And only one of two ports on the Syrotech modem is gigabit.
What could be the problem? Could it be that the modem just can't handle very high speeds and crashes?
 
Do check the power adapter, if it's faulty and not able to supply enough power the device might restart. Try swapping with another with higher amperage rating. Btw what's the current power adapter specs?

If it's not the power supply, it could be the IPv6 implementation on the device. Syrotech/Netlink are all cheaply made Chinese devices, so as a router it may not perform well.

I'd recommend using it as a pure bridge modem and use a different router.
 
Which ONT is this exactly? Is this the model with wireless too? (Syrotech has many models, all Chinese rebrands though 😅)

The model with wireless would need a 12V 1A adapter, at higher load it could consume more than 6w. I think at idle I've measured 4-5w.

Anyway, if possible get a TP-Link Archer C6, good price/performance ratio, as router and for wireless. Use the Syrotech as a modem in bridge mode.
 
yep it's the one with 2.4ghz-only wireless. The adapter is smaller and lighter than mobile chargers these days (might be an exaggeration).

I'll try to buy one if Amazon decides to actually deliver it. Will see what happens.
 
@shin I figured out the issue accidentally. When you change to ipv4/ipv6 or just ipv6 the MTU changes. Everything seems fine until you do a speed test. The download test works in my case but when the upload test starts the ONU crashes.
 


Not too sure about that. Because right now I'm running my ONU in bridge mode with an old DSL modem/router with IPv4/IPv6 and I'm able to get around 100mbps both on speed tests and actual large downloads with no problem. I also tried using multiple clients all downloading and uploading together to stress the router as much as possible. Everything is fine on bridge mode.

As for the MTU, I confirmed it after changing to ipv6. I set it at 1492 which is the max you can do on PPPoE. I also tried lowering it.

Now that I think about it the ONU used to reboot randomly sometimes even in IPv4 & stock settings that BSNL guys configured.
 
When you had this issue you were using the Syrotech ONU and not your router in bridge mode, isn't it? And MTU is 1452 for me, may be it's different for you.
 
I'm getting the same issue, but this usually happens after half an hour or so. My mobile devices keep connecting and disconnecting and only my laptop stays connected with very slow internet. At this time I cannot login to the router configuration web page. I have to unplug and restart the Syrotech router.
 
The router is terrible. There are multiple problems with it. I recommend running it in bridge mode with some aftermarket router. Archer C6 is a good one. Many here recommends it.