Syrotech ONU not saving Network settings | unable to enable Telnet also | port binding?

  • Thread starter Thread starter maverick27
  • Start date Start date
  • Replies Replies 39
  • Views Views 10,357
Messages
66
Location
Dehradun
ISP
BSNL
Hi all!
I recently switched to BSNL FTTH from BSNL ADSL.
Connection is provided by LCO.

My ONU saves settings in the Network section only temporarily.

I have to manually add static routes, and configure settings (both for VOIP), whenever the ONU reboots. This is very frustrating.

The LCO is a noob and says if there would be an issue from their end, it would reset the entire ONU settings, and not just the Internet and VOIP profiles.

What is the purpose of Port Binding? It seems to make no difference to my connection, except that i need to disable it on the WLAN ports for VOIP apps to function on my phone. And, like other settings under Network, it too gets enabled for all ports post reboot.

In addition, I'm unable to enable Telnet to do any form of troubleshooting. The moment I hit Submit, the checkboxes simply get unticked themself.

A strange thing that i noticed is that it shows ACS set success in the ACS section after every reboot, even though I've disabled TR069. And the TR069 disabled state persists after reboot.



I've raised my concerns with Syrotech support over mail, but am yet to receive a response even after 2 weeks or so.

Device model: SY-GPON-1110-WADONT
Hardware Version:V1.3
Firmware Version:V2.0.19-200818
ISP: BSNL


I've followed this forum for long, and hope that somebody would be able to help me. Especially looking forward to inputs from @varkey @sloj @Nikhil Sharma @JB701


Thanks in advance, folks!
 
Last edited:
Try this, do a reboot and then save the config via Management tab. Now reset and check if the config comes back. If it does, it means they probably do it from their end via OMCI.
Port binding is a way of making a port exclusive to a particular profile like Internet or VOIP.
 
Have you enabled logging?
I tried a couple of things today. Managed to telnet into the ONU, only to discover that it had a very limited set of commands. I was following the process mentioned by @Nikhil Sharma in:



I then FTP-ed into the ONU and deleted the lastgood.xml_bak files from both /var/config and /etc/config. Then, to check if settings persist, i disconnected the PON input and then rebooted the ONU. The settings persisted. And, somewhat to my surprise, the lastgood.xml_bak files were back too! However, the moment i plugged in the PON, the settings were back to square one. This makes me feel that that file is not the culprit. It must have something to do with the OLT.
 
Try this, do a reboot and then save the config via Management tab. Now reset and check if the config comes back. If it does, it means they probably do it from their end via OMCI.
Port binding is a way of making a port exclusive to a particular profile like Internet or VOIP.
Is there a way that OMCI could be rejected buy the ONU? Maybe resetting or setting some flag?
 




I then FTP-ed into the ONU and deleted the lastgood.xml_bak files from both /var/config and /etc/config. Then, to check if settings persist, i disconnected the PON input and then rebooted the ONU. The settings persisted. And, somewhat to my surprise, the lastgood.xml_bak files were back too! However, the moment i plugged in the PON, the settings were back to square one. This makes me feel that that file is not the culprit. It must have something to do with the OLT.
You should delete syslogd.txt if it was the logging bug. If that didn't work, blame the OLT.
 
Is there a way that OMCI could be rejected buy the ONU? Maybe resetting or setting some flag?
Unfortunately, no. The LCO or ISP do it to maintain things remotely for convenience. You will have to ask if they can exempt your device.
 
two scripts under /etc/scripts - reset_default.sh and config_xmlconfig.sh - seem to be causing this bug. If the steps outlined by @Nikhil Sharma don't solve this, flashing may be the only answer. But the only version I was able to find a download for - Syrotech_BSNL_2_1_1.0.26-200308.tar from NEED SYROTECH FIRMWARE | BSNL Bharat Fiber Broadband - has this bug (it's also the latest available on FTTH Facilitation Center.

For HG323 devices, I've checked that 1.0.35 version (from HG323RGW problem on BSNL Bharat Fiber Broadband | BSNL Bharat Fiber Broadband) may not have this since the reset_default script is commented out in it.
 
Last edited: