Configured VoIP from BSNL Fibre on Opnenvox Asterisk IPPBX with Huawei HG8546M ONT in standard configuration without Bridge Mode in Chhattisgarh.

Yes!!! Finally I was able to do it.
For long , I had been trying to configure the VoIP from my BSNL fiber connection on my Open Vox UC501 Asterisk based home IPPBX.
Now to start with , this article was the basis for my efforts.
My Huawei HG8546M ONT has standard configurations for Internet WAN. Regarding the VoIP WAN I configured it in Voice-Internet form in route mode.
In the ONT I also set static routes to the VoIP server domain cg.ftth.ims.bsnl.in and also to ip 10.0.0.0 (as cg.ftth.ims.bsnl.in resolves to 10.191.177.49).

Fortunately, on my IPPBX I have separate WAN and LAN ports. LAN port is connected to my router (which is situated downstream from the ONT) on the Local Network . The WAN port is connected directly to the ONT LAN port and configured in DHCP mode. Here, I kept the ONT (192.168.100.1) as Primary DNS server and 8.8.8.8 as the secondary DNS server. On the IPPBX , I also created a static route to 10.0.0.0 with gateway as 10.146.24.1 (this is the gateway for voice on my ONT).

Next, I configured the Voice as PJSIP trunk on my IPPBX with credentials as were there on my ONT.

Bingo..... it works.

Instead of IPPBX, one can use the same method to configure the VoIP on a Soft Client or IP Phone . I have tested these as well. it works.
 
Last edited:
Why did you need static routes on your OpenVox if the OpenVox isn't technically routing anything in L3? It should ideally just have one default route 0.0.0.0 to your gateway IP (10.146.24.1). Even that needn't be set since the OpenVox is getting routes and IP details via DHCP from your ONT, which is in route mode. Your ONT will route voice traffic out via the Voice WAN, since you've added routes there. This step can be avoided if you are setting sip details in your clients such that they use the OpenVox as the sip server, and not BSNL's servers.

Your main router is the one that needs routes set so that voice traffic from SIP clients on your LAN can be sent to the OpenVox. So you need to set 10.0.0.0 to <enter OpenVox LAN IP here> in the main router.

Kudos for getting this to work but the entire setup is kinda messy. But hey, if it works, why mess with it and break it? Congrats again 🙂
 
Thanks @pillaicha. There is another SIP trunk configured on my Openvox. Its configured to connect to the Internet through the LAN port>> Main Router>>Internet. To keep this separate from my BSNL SIP, I created the Static route in the Openvox. Prior to setting up this Static Route on the IPPBX, the two SIP trunks were behaving erratically.
 
Then why not just bridge the BSNL's voip profile from ONT to OpenVox? Currently you have two layers of NAT for your voice traffic to BSNL via the ONT and the OpenVox.

Create a VLAN tagged/untagged WAN page in bridge mode on ONT(depends on the way the bridge in the ONT works; so try tagged and untagged)
and then port bind it to any LAN Port of ONT. Connect that to the WAN port of OpenVox and enable DHCP (for WAN) in OpenVox.

If OpenVox gets an IP in the 10.x.x.x range from BSNL upstream, then you've avoided that layer of NAT. Rest of the routing can be left the same since I'm assuming you've set it up correctly in the main router itself.

Out of curiosity, which device is performing DHCP for your sip clients? Is it your main router, or is it the OpenVox with DHCP pass-through on the main router ports? Are you running voice on a different VLAN within your network? If not, do the IP phones in your network have access to the internet as well as the OpenVox?
 
Hi @pillaicha. The very reason I posted this article with standard ONT configurations is that I could not make this work even with repeated efforts earlier using various methods like ONT Bridging, VLAN tagging, Openwrt router etc. mentioned elsewhere in this forum. I used different ONT (Syrotech and Huawei) but could not make it work somehow.
I don't know whether it had something to do with the ONT or the network of BSNL or whether I was getting it wrong altogether. That is why I felt necessary to write down mTwo static routes configured on my IPPBXy methods using the ONT in standard configuration and for BSNL network in my part of the country.
Its basically meant to be guide for people like me who are not so much into expert networking as most other guys here.
My network is still a bit complicated though, as I using multiple broadband connections with load Balancing.
So, I have my ONT's ( BSNL and Airtel) connected to an Openwrt Load Balancing Router which in turn Connects to my main Router (Netgear 6350) downstream. The Netgear 6350 is the DHCP server of my home network. I have used the Netgear 6350 as my main router instead of the Openwrt because of its user friendly interface ( again because I am still a beginner at all this).
So all my IP phones and Soft Clients are on the Netgear 6350 network. The IPPBX server is also on this network through the LAN port. While the WAN port of the IPPBX bypasses the Netgear 6350 and Openwrt and is connected directly to the BSNL ONT (as I have mentioned in the original post) for the BSNL SIP. The second SIP trunk (BSNL Wings) is configured to access Internet from the LAN side of the IPPBX. Hence you would see TWO static routes configured on my IPPBX:- First one for ip 10.0.0.0 with 10.146.24.1 gateway (voice gateway for BSNL fiber) through the WAN for BSNL SIP. The second one for ip 218.0.0.0 with 192.168.2.1 gateway (my main Netgear 6350 router ) for BSNL Wings SIP to connect from LAN side. I am again sharing a Screenshot of the LAN and WAN parameters of my IPPBX.
 
Hi , can you please help from where can we find ont ip address? ( To keep it as primary dns server ) and I don't have option for setting route for domain in my ont and router what can be done for it ? I am unable to ping tn.ftth.ims.bsnl.in where as I can ping it's ip address. So I am unable to register on zoiper , gswave or other apps . Getting dns server error.
Thanks
 


Hi @Prakashmishra. If your ONT is your router also then the the gateway address for network would be your ONT's IP address.
If the Domain name is being resolved correctly, then you can, straight away, set a static route for the IP address the domain name resolves to.
Make sure you are using DNS on BSNL network. If you are using another ISP network, probably it won't resolve tn.ftth.ims.bsnl.in. Moreover the domain is available only the Voice VLAN of BSNL connection (which was 1849) in my case.

So suppose, on your connection you have internet on VLAN x and Voice on VLAN y. Then your Internet WAN profile (say WANx) would use VLAN x and voice - Internet Profile (say WANy) would use VLAN y. Now your DNS for tn.ftth.ims.bsnl.in should be on WANy as well as your static route for corresponding ip address should be configured through WANy.

Make sure your Voice WAN profile is configured as Voice_Internet or Internet (depending on the ONT).
 
Last edited:
@Audioctor your setup looks great, I have pfsense and did things little different and was able to get Grandstream phone to connect BSNL Voip Services without any issue as stage one, stage two wanted to configure BSNL Voip SIP in freepbx (disabling Grandstream Trunk) but having great deal of difficulty.

Wanted to know in your setup did you use pjsip or Chansip for configuring Trunk