How to make my router the only DHCP server?

  • Thread starter Thread starter rioreo
  • Start date Start date
  • Replies Replies 13
  • Views Views 2,316
Messages
7
Location
TN
ISP
Local
I recently switched from BSNL to a local cable provider ISP. They provided me with the optilink modem which has only one port and I connected my old BSNL ADSL modem/router to it as an access point. The problem is, whenever I connect more than 4 devices to my access point, my laptop gets disconnected and my modem goes through a restart cycle. I want to use my BSNL router as DHCP server and I tried many solutions from the forum but I can't quite figure it out.

This is what I did so far:

1. Reset my ADSL router and turned on the DHCP server in it. And turned off the DHCP server in trash optilink modem. But after a restart, the optilink DHCP server turns itself on. My mobile devices get ADSL as gateway and can't access internet.

2. Turned off NAT in trash optilink modem and turned on NAT in ADSL router, but the internet doesn't work.

I want my local network traffic to be handled only by my router/access point and not the optilink modem. For eg. I turn on plex in my laptop to watch movies in my smart TV and the route the data goes through, I assume, is Laptop ---> Access point ----> Optilink modem ---> Access point ---> TV. I want to skip the modem part. Is it possible to do this? If I should buy a separate router with WAN port, I can do it. Please recommend one too. Please help me. Thanks.

P.S. I am attaching the diagram of my rather simple network here for reference.

sTdmwHD.webp
 
Last edited by a moderator:
You need a router with a WAN port if you want it to be the DHCP server within LAN.

As far as the route diagram you showed, it is false. The data will not go to the optilink modem. It can switch at L2 itself within your LAN between devices. Only Internet bound traffic will go to/from the Optilink.

NAT is a WAN feature. You can’t turn off NAT in optilink and expect Internet to work. NAT for ADSL router is pointless since there are no WAN profiles in the ADSL router.

TL;DR Buy a modern WiFi 6 capable router, put your Optilink into bridge mode, connect the ethernet cable from Optilink to WAN port of new router, enable PPPoE in new router and you should be good.
 
Just adding it here in case you want to experiment.

  • Set ADSL router to static 192.168.10.1/24, subnet 255.255.255.0.
  • Enable DHCP in ADSL router with gateway as 192.168.10.1, subnet as 255.255.255.0, LAN Start Ip from 192.168.10.3.
  • Disable NAT In ADSL router.
  • Add a static route rule in ADSL router: 0.0.0.0/0 to gateway 192.168.10.2.
  • Set Optilink to Static 192.168.10.2/24, subnet 255.255.255.0.
  • Enable NAT only in Optilink. Disable DHCP in Optilink.

All this extra work isn't really necessary to be honest. Just enabling the DHCP option in the Optilink while using your ADSL router as a managed switch will be good enough for most use cases. Like I said before, your data from laptop to TV doesn't pass through the Optilink since it's all within the same broadcast domain and can be L2 switched through the ADSL router.

If you particularly need the DHCP function of the ADSL, then you can do so by turning off the DHCP of the Optilink and turning on the DHCP option of ADSL router but make sure gateway option is the IP address of the Optilink modem.

Lastly if the DHCP functions of Optilink keep turning off after reboots, then the only other option is to leave it on, but on a subnet different to your ADSL router and all other devices. Add a static route if necessary in ADSL router and set gateway to ADSL router's Lan IP address.
 
Last edited:
Thank you so much for the detailed explanation. Sorry for the late reply as my hands were tied on work.

You need a router with a WAN port if you want it to be the DHCP server within LAN.
That makes sense. Do you have a recommendation? I can spend around 2500 rupees +/- 500. I see Archer C6/A6 recommended here frequently but I am confused on which one to choose.

As far as the route diagram you showed, it is false. The data will not go to the optilink modem. It can switch at L2 itself within your LAN between devices. Only Internet bound traffic will go to/from the Optilink.
That makes sense too. In fact, I was 90% sure that I was wrong but I added it anyway so that I can get better explanation. So packet route is from laptop to my AP to my TV since TV is also connected to AP through CAT 5e. Makes perfect sense, thanks.

NAT is a WAN feature. You can’t turn off NAT in optilink and expect Internet to work. NAT for ADSL router is pointless since there are no WAN profiles in the ADSL router.
I understand.

TL;DR Buy a modern WiFi 6 capable router, put your Optilink into bridge mode, connect the ethernet cable from Optilink to WAN port of new router, enable PPPoE in new router and you should be good.
I will buy a router and definitely try this. But I have no idea how to do this. My present ISP is a local one and I am, again, 90% sure that my optilink modem is bounded with their equipment somehow.

Just adding it here in case you want to experiment.
I did this "experiment" and the results were disastrous lol. The mistake is on my side obviously. Nevertheless I learned many things by doing it.

If you particularly need the DHCP function of the ADSL, then you can do so by turning off the DHCP of the Optilink and turning on the DHCP option of ADSL router but make sure gateway option is the IP address of the Optilink modem.
I did this and I couldn't reach my modem. I know if I turn off DHCP, I can't reach it. The internet was working fine too. But my LCO guy would change some setting regularly because they are expanding rapidly(They add new equipment every month!). So I reset my modem, but couldn't reach it. But I got it to work somehow. No problems now.

Lastly if the DHCP functions of Optilink keep turning off after reboots, then the only other option is to leave it on, but on a subnet different to your ADSL router and all other devices. Add a static route if necessary in ADSL router and set gateway to ADSL router's Lan IP address.
Okay. I will try it but I think I will buy a new router!! Please recommend a good one.

Thanks for your time @pillaicha
 
Do not change default ip adress of adsl modem router, let it allot dhcp ip address in that series. Try accessing both now.
 


@pillaicha Thank you so much.

@Oppili I did that too. My PC and laptop got assigned 192.168.10.1 as default gateway and could connect to internet but my Wi-Fi devices got assigned 192.168.1.1 as default gateway and couldn't access internet. I know that I must have made some mistake somewhere but it's beyond my understanding to diagnose the problem. I will use this ADSL Wi-Fi router as a dumb switch somewhere in my home and better buy a good router for everything else. Thanks for your time oppili.
 
C6 user here. Pretty happy with the price to performance aspect. Unless you have high requirements, C6/A6 should suit your requirements.