BSNL FTTH dropping every 20-30 minutes when using ONU in bridge mode

  • Thread starter Thread starter gizmosaurabh
  • Start date Start date
  • Replies Replies 12
  • Views Views 8,395
Messages
17
Location
Lucknow | Mumbai
ISP
Railwire - Lucknow
Hathway - Mumbai
Hi All,

Recently I have started facing a strange issue with BSNL FTTH connection.
I use the cheap Syrotech GPON ONU (no other option) in brige mode with a dual band TP-Link Router.
It was working good until last week when a strange problem started appearing.
My Internet gets dropped every 20-30 minutes (red light on WAN indicator on the TP-Link Router) and once that happens the internet doesn't work for hours and in 3-4 hours it starts working automatically without me doing any config changes. And in the next 20 minutes disconnects again and the cycle continues.
To troubleshoot, I tried using the ONU in router mode by disconnecting my TP Link router and the connection works fine for 2-3 hours now, but the same cycle continues just with increased time. Cross checked with neighbours to confirm if it's a local issue or mine only, I tried using the TP Link router at a friend's place who has a railwire line and the router works fine. So there seems to be no technical issue with the router.
Contacted the LCO and he checked the OLT and noticed that my ONU profile disappears from the list of users on the OLT. Unable to figure out what exactly could be the issue. Anyone faced any similar issue earlier? Could insufficient power be the factor?

1601550716330.webp
 
Last edited:
Have you tried cloning your MAC from the onu to router? Worth a shot.
 
Thanks for your response Adithya. I tried cloning the mac. That didn't help.
I confirmed from the BSNL NOC at Noida that there is no Mac binding in place.
Also, I never turned on Mac cloning earlier and never faced any issues. So doesn't seem to be like a mac cloning issue.
 
Your RX power seems to be at the limit of a good signal. Could that be the reason?
 
Yeah that's the only thing I could figure out till now.
Have asked the LCO to increase the power. Let's see.
But checking in the forum if anyone might have experienced similar issue and might have some solution.
 
@gizmosaurabh Just saw your post so replying in case its helpful.
I'm seeing similar issues with my BSNL FTTH connection in Pune. I use the BSNL provided Optilink ONT in bridge mode, and a Ubiquiti ER-X as my router. After months of working fine over the past several days something seems to have gone off. The connection breaks and won't reconnect without a reboot. Nothing on the ONT indicates anything off (all green lights). I suspect something in the pppoe settings has gone off (based on the log messages on the ER-X) , though I haven't made any changes to my config at all....no idea what or how to fix it yet though.
 


@networkwhisperer Thanks for your response. I managed to get it sorted out.
1. The ONT RX Power was on the lower side. Got that increased (LCO cleaned the fiber with Isopropyl alcohol) and it fixed the random drops. Pretty stable connection now. Also when I contacted Syrotech customer care they gave me a newer build of the firmware. Don't really have a changelog but somehow that fixed the issue where the ONT settings didn't persist after a reboot (my settings didn't persist even if the ONT didn't pull the config from OLT).
2. I was facing frequent disconnects from my TP-Link router (syslog had too many NAT events with the label Flush Conn track [flush connection tracking may be] and multiple Initialization events as well). This seems to be a widespread issue because within 2-3 days of facing this issue a firmware update was published for the TP-link router too. That fixed the TP-Link disconnect issue too.
Having a pretty stable connection now (Fortunately lol).

My suggestion would be:
1. Check your RX Power on the ONT. It should be below -24 dBm (Logically Higher). May be you can post how much power you're receiving so can have a look.
2. Check syslog on your router for any unusual events (Though your router seems to be a high end one and must be robust enough, so chances of router issue are low). Ensure connection mode in PPPoE settings is Auto.
 
Thanks ! The Rx power is -15.9 dBm. I noticed the MTU setting seemed to have been reset somehow (there's been some power outages, not sure if that had a role) so I tried tweaking that and it's been up for 5.5 hours now. I'll see if it lasts...
 
So does it come back to connected state automatically after disconnecting? PADO means PPPoE Active Discover Offer packets. These are generated when the router dials the PPPoE line to connect to the internet. PADO errors generally occur due to connectivity issues between your modem/ont and the ISP. I would suggest some trial and error methods to try to fix it.
1. Contact the ISP to clear your fiber line once. May be switch you to a different port or splice the fiber again. Your RX Power is good so doesn't seem like a signal issue.
2. Try setting the MTU to 1460 on both (Your ONT and Router). Some ONTs allow to set the MTU even in bridge mode.
3. Ensure you turn off LAN DHCP on the ONT.
4. Also, if nothing works, try to use the ONT as a router for sometime and observe if the issue still occurs to figure out if any of your router or ont are faulty.
I assume you have already tried hard reset on your Router and ONT.
 

Back