Nokia G-140W-F bridge mode?


I had my connection changed from DSL to FTTH and Airtel gave me a Nokia router. The model comes with the following WAN config,


Under WAN settings I created a new connection with IPOE mode and same VLAN 100,


Also I changed the port 4 to Bridge mode.


The router restarts at this point. Port 4 blinks momentarily blinks on bootup but then stops detecting the LAN cable. It seems that the port gets disabled. The Ports 1 and 2 however do remain up when set to bridge mode.

@napsterX The solution in this post doesnt seem to be working for this model.
Last edited:
Following is the screenshot from my Huawei EG8145V5 router which is setup in bridge mode. Comparing this with Nokia router configuration, it seems we are missing the option 'Bridge Wan' under 'WAN Mode' in the Nokia router.


Also, notice that connection name in the HUAWEI router '2_Internet_B_VID_10' is similar to the Nokia router ('2_Internet_R_VID_100'). The 'B' in the name refers to bridge while 'R' in Nokia refers to routing. Maybe the 'Bridge' option in 'Wan mode' is actually there but not exposed in the Web UI.

The usermanual for G-240W-F shows similar UI to this router.

The router sticker looks like so,
Last edited:
The router/GPON has a telnet interface. Unfortunately, the console does not provide a facility to configure the router,

Hello, Welcome to User CLI (version 0.95).
user> show version
Zebra 0.95 (mips-linux).
Copyright 1996-2004, Kunihiro Ishiguro.

user> en

  configure   Configuration from vty interface
  disable     Turn off privileged mode command
  exit        Exit current mode and down to previous mode
  help        Description of the interactive help system
  list        Print command list
  logout      logout and byebye.
  nslookup    Query nameserver for the specified host
  ntp         Date and time in UTC that of the CPE when it sync with SNTP server.
  ping        Send echo messages
  shell       start shell, need to input the dynamic password
  show        Show information from vty interface
  tftp        Transfer syslog,omci,voice log to tftp server.
  traceroute  trace route about a host

user# con

  end      End current mode and down to previous mode
exit     Exit current mode and down to previous mode
  help     Description of the interactive help system
  list     Print command list
rsyslog  Configure rsyslog file size and beacon log level.
  syslog   Configure syslog file number and file size.
user(config)# list
  rsyslog rgw_filesize <1-5> rgw_loglevel <0-7> beacon_filesize <1-5> beacon_loglevel <0-7> [remote_ip A.B.C.D] [persistent FLAG]
  syslog filenum <1-5> filesize <1-5> [persistent FLAG]

Internally it is running the same software as G140WC,
user(show)# buildinfo

There seems to be and old config in the router,
user(show)# swversion
Software Image #0:
version = 3FE47150DGAB98
is active = Yes
is valid=Yes
is committed =Yes
Software Image #1:
version = 3FE47150DGAB44
is active = No
is valid=Yes
is committed =No
Boot version =U-Boot Dec-31-2016--12:00:00
Last edited:
Did anyone find a way how to do this? I am thinking of an alternative but I don't know how effective its going to be.

My idea is to connect my 2nd router (R2) to the Nokia (R1) one, R2.WAN->R1.LAN, assign R2 a static IP, set up DMZ in R1 to that IP and then use R2 for all my devices/computers. I will switch off the Wifi and other stuff on R1 (there is a button for wifi on/off). I ordered the TP-Link Archer C6 for its OpenWRT support and will get it in a couple of days.

I think this idea somewhat solves the double NAT issue but, I would prefer the Bridge mode!

Also, if in theory, lets say the bridge mode thing starts working, how do I get the login credentials for the PPPoE connection so that I can set it up in my router?

Yes, the DMZ method works. I tried it with the Nokia router.

The pppoe username is visible in the Nokia router settings, while the password is simply your account number. You can get that from Airtel.

I ended up buying a Huawei HG8145V5 router from OLX which had bridge support and got rid of the Nokia router. Problem with running a closed router like Nokia is that you are dependent on Airtel for firmware updates. Using Openwrt or pfSense is way better since, these are updated regularly.
Last edited:
@rajil.s Thank you!

I was just searching around Amazon and found ONUs like this


Can I use them as a bridge between the OFC termination and my own Router, eliminating the Nokia one completely?

What do you think the chances are that Airtel is gonna give me a bridgeable router or an ONU if I ask them? I am still waiting for my TP-Link Archer c6 to come.

Finally, how much did you pay for the Huawei HG8145V5 ?

Airtel will not let you use off-the-shelf ONU. Their backend has some sort of software which recognizes only few router types. Theoretically, it is possible to use any ONU but their backend staff is not that competent or don't want the hassle of configuring manually.

Buying a Huawei router yourself is the best option. If you don't want to go down that path then another alternative is to ask for an old Alcatel router model I-240G-D. It is in bridge mode out of the box. The downside with this is that the webui username and password is not known to anybody. It doesn't exist in Airtel system but they do provision it. You may have a hard time getting it from your local Airtel technician as it is an old model. No wifi on it though but does support telephone line.

There are lot of people on olx selling Huawei router, price depends on your negotiation skills 🙂
Hi rajil.s,

Can we just replace the Nokia ONU with Huawei ONU (from another Airtel customer). Is the ONU locked to a customer?

Does Airtel has to change from their side anything if we replace from Nokia to Huawei ourselves?
@Rehan Kumar That's TR-069. Nothing was enabled on "their end" for bridge mode to work. They likely disabled the functionality and re-enabled it via TR-069.

Which is a good thing from a business perspective? At least they are following standards. Unlike Jio Fiber.
Kudos to @Rehan Kumar for showing me his Nokia router settings over a remote connection. It is indeed doing a bridge mode.
His settings were:

In Network> Lan
1. Disable 'All ports to Bridge Mode'
2. Enable Bridge mode for 'Port 4' while leaving rest on 'Route mode'

In Network>Wan
1. Change Connection type to IPOe
2. Enable NAT
3. Service: Tr069/Internet
4. Enable VLAN ID and set it to 100
5 VLAN PRI is 0
6. WAN IP Mode is DHCP.

I suspect the Network>WAN setting dont mean much, since only Ports 1-3 are put in routed mode. It is the Port 4 which is being bridged.
@kgru Apparently, you will need Airtel's help to put your router in bridge mode. The setting i posted above are from @Rehan Kumar who was able to get bridge mode working.

My personal opinion is to throw-away this Nokia router and get a Huawei router instead which offers native bridge functionality.