Alexa Echo to Alexa App calling not working with BSNL FTTH

vishalrao

The Global Village Idiot
Messages
6,394
Location
Pune
ISP
Tata Play 1 gbps, Jio AirFiber 100 mbps. Prior Microscan 500 mbps, PDPL 300 mbps and BSNL 300 mbps.
Hello!



Has anyone been able to get Alexa to successfully call from an Echo device to the Alexa app on Android phone with BSNL Bharat Fiber connection?



When I try to say "Alexa, call Vishal" I observe that the phone screen turns on and that's it, nothing else happens.



Note that if I try the following 3 things it works, leading me to believe it's some problem with the BSNL FTTH connection.



1. I disabled my phone Wifi and switched to my 4G data connection then it works, the Alexa phone app rings properly.



2. I've also tried changing out my Netgear RBK50 mesh with a Netgear R8000 with the same issue. I don't have non-Netgear wifi router to test ATM.



3. I tried using my Airtel 4G wifi CPE device instead of BSNL+router and it works with this too.



Would trying to get a static IP from BSNL help in this case? Any ideas how to resolve this issue?



Thanks!
 
I am able to do it on my iPhone both to my echo dot from the Alexa app and vice versa, but the echo to mobile number doesn't connect.
 
Upvote 0
You are on bsnl ftth? What router do you have? You have static ip by any chance?
 
Upvote 0
Subnet in dhcp is 255.255.255.0

The bsnl wan pppoe subnet shows as 255.255.255.255

I 🧐
 
Upvote 0
Okay that's normal setup. So it's some other issue then. I was suspecting maybe broadcast traffic was disallowed due to subnet misconfiguration.

Hopefully you aren't running multiple VLANs within the network? Or setup any ACLs on the router for different devices?
 


Upvote 0
Nope nothing like that. Thanks for your inputs!
 
Upvote 0

Back